找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 874|回复: 0

[脚本] dynv6 IPV6 DDNS不成功

[复制链接]
发表于 2024-4-9 21:34:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有账号?注册

×
本帖最后由 qwert1388 于 2024-4-9 21:36 编辑

:local hostname "sz.mkadmin.dns.army"
:local token "edZkL1ZVv8fidonfA1Sxd-XyqSx-xH"
:local IPV6 [ipv6 address get [ipv6 address find interface=pppoe-out1] address]
:set IPV6 [:pick $IPV6 0 ([len $IPV6] -3)]
:if ([:resolve $hostname server=1.1.1.1] != $IPV6) do={
/tool fetch url="http://dynv6.com/api/update?hostname=$hostname&token=$token&ipv6prefix=$IPV6" mode=http keep-result=no
:log info "IPV6 Update: $hostname - $IPV6"
}



下面官方更新信息

Use the following snippet in your ddclient.conf of ddclient:protocol=dyndns2server=dynv6.comlogin=nonepassword='edZkL1ZVv8fidonfA1Sxd-XyqSx-xH'mkadmin.dns.armyAdditionally you also need to specifiy the interface to use, like use=if, if=eth0Fritz!OS (German)Enable IPv6
Go to Internet → Zugangsdaten → IPv6 Make sure that IPv6 support is enabled. If your provider does not support native IPv6 yet, then enable tunneled IPv6 with 6to4.
Set up dynv6
Go to Internet → Freigaben → Dynamic DNS then enable the Option Dynamic DNS benutzen select the provider Benutzerdefiniert and copy the following values into the form:
Update-URLhttp://dynv6.com/api/update?hostname=<domain>&token=<username>&ipv4=<ipaddr> http://dynv6.com/api/update?host ... lt;ip6lanprefix>
(combined with whitespace to update IPv4 and IPv6 addresses simultaneously)Domainnamemkadmin.dns.army
BenutzernameedZkL1ZVv8fidonfA1Sxd-XyqSx-xH
Kennwortnone


routeros
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|Archiver|手机版|小黑屋|软路由 ( 渝ICP备15001194号-1|渝公网安备 50011602500124号 )

GMT+8, 2024-6-16 11:48 , Processed in 0.040071 second(s), 4 queries , Gzip On, Redis On.

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表